Login Environment
/etc/profile - main profile for all users
/etc/profile.env
export TMPDIR=/tmpsort
export TEMPDIR=/tmpsort
source a profile: ". ./profile"
Changing prompt:
export PS1=$(hostname):'$PWD # '
This gives a prompt that has the hostname followed by the current directory, ending in the # (useful for root logins).
/etc/profile.env
export TMPDIR=/tmpsort
export TEMPDIR=/tmpsort
source a profile: ". ./profile"
Changing prompt:
export PS1=$(hostname):'$PWD # '
This gives a prompt that has the hostname followed by the current directory, ending in the # (useful for root logins).
Networking
netstat -a <--ports
netstat -i <--interfaces
netstat -r <--routing table
netstat -rv <--routing table and subnet mask
lanscan - provides hardware information about the nics in the server
lanadmin - menu driven interface to administer lan nics
lanadmin -x 0 bypass menu and show lan driver specific options for nic with id 0
lanadmin -X 100FD 0 - bypass menu and set nic at id 0 to 100 MBS, Full Duplex
ioscan -fnkC lan - shows ioscan information for device type "lan"
lanscan -i|awk '{print $1}'|xargs -i ifconfig {} -> does an ifconfig on all defined interfaces on that server
Changing the IP Address and Subnet mask:
netstat -i <--interfaces
netstat -r <--routing table
netstat -rv <--routing table and subnet mask
lanscan - provides hardware information about the nics in the server
lanadmin - menu driven interface to administer lan nics
lanadmin -x 0 bypass menu and show lan driver specific options for nic with id 0
lanadmin -X 100FD 0 - bypass menu and set nic at id 0 to 100 MBS, Full Duplex
ioscan -fnkC lan - shows ioscan information for device type "lan"
lanscan -i|awk '{print $1}'|xargs -i ifconfig {} -> does an ifconfig on all defined interfaces on that server
Changing the IP Address and Subnet mask:
- set_parms ip_address
- Then supply ip address and subnet mask when prompted. This process will require a reboot.
Changing the Default Gateway
Command | Description |
cancel | deletes print jobs from queue |
hppi | jet admin |
ls -d | prints a file |
lpadmin | |
lpsched -v | |
lpstat | lists jobs in queue. -s -t |
pr .profile | lp -n3 | prints |
pr -o10 -l64 -F -h | prints using margins of 10, page length of 64, header on each page |
- cd rc.config.d
- vi netconf
Network Time Protocol (NTP)
ntpq -p --> lists ntp peers and their time sync status
ntpq -p --> lists time sync status with that server (slightly different detail than ntpq -p)
/etc/ntp.conf --> configuration file
Changes to the configuration require ntp daemon (xntpd) be stopped and restarted (restart is not recognized):
ntpq -p
/etc/ntp.conf --> configuration file
Changes to the configuration require ntp daemon (xntpd) be stopped and restarted (restart is not recognized):
- /sbin/init.d/xntpd stop
- /sbin/init.d/xntpd start
0 Comment to "HP-UX Overview and Command Summary - page 4"
Post a Comment